View Full Version : There was a problem authenticating your download

05-08-2010, 06:00 AM

I'm new here so i don't know if this post is in the right place..

As I know many others have this problem I'll post the solution that worked for me.

for 2 days I have been having trouble starting the blizzard application installer (the one that extracts the starcraft 2 beta installer) from the battle.net account management site. I got this message: There is a problem authenticating your download. I read on other forums that the solution is to start the blizzard application file as administrator by rightclicking the file and selecting the run as administrator. This did however not solve anything as I was already logged in on my computer as administrator.

What worked for me was the opposite. I created a new profile on my computer without administrator rights and unziped the application starcraft 2 install exe file. Then i logged out and back in again as the administrator and started the download. Everything after that worked fine... I hope this works for you guys as well..

Strange issue, and I have no idea why this worked..

05-08-2010, 01:47 PM
If there was a problem yo I'll solve it


05-24-2010, 03:17 AM
I think you didn't quite understand the point of this part of the forum. This is not to give feedbacks about the game but to give feedbacks about our website.