Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: Woah, did the forum just lose months and months worth of content?

  1. #21

    Default Re: Woah, did the forum just lose months and months worth of content?

    Quote Originally Posted by TheEconomist View Post
    (No one reads this shit though)
    Not entirely anyways, but people still skim.

  2. #22

    Default Re: Woah, did the forum just lose months and months worth of content?

    Server had issues. Former backup of the site was uploaded. LoA fixed that.

    Sorry part of your thread was lost.

  3. #23
    TheEconomist's Avatar Lord of Economics
    Join Date
    May 2009
    Posts
    6,895

    Default Re: Woah, did the forum just lose months and months worth of content?

    Sorry part of your thread was lost.
    The world will forever be less for lack of its genius.



    Rest In Peace, Old Friend.

  4. #24

    Default Re: Woah, did the forum just lose months and months worth of content?

    Mandela effect. Unfortunately, it got noticed. Cern has some explaining to do.

  5. #25
    TheEconomist's Avatar Lord of Economics
    Join Date
    May 2009
    Posts
    6,895

    Default Re: Woah, did the forum just lose months and months worth of content?

    I'm a victim of the Mandela Effect, and was thoroughly mind-fucked by the Berenstain event too.



    Rest In Peace, Old Friend.

  6. #26

    Default Re: Woah, did the forum just lose months and months worth of content?

    We are currently living in the post-Berenstain universe

  7. #27
    TheEconomist's Avatar Lord of Economics
    Join Date
    May 2009
    Posts
    6,895

    Default Re: Woah, did the forum just lose months and months worth of content?

    We are currently living in the post-Berenstein universe
    Don't let them get to you!



    Rest In Peace, Old Friend.

  8. #28
    TheEconomist's Avatar Lord of Economics
    Join Date
    May 2009
    Posts
    6,895

    Default Re: Woah, did the forum just lose months and months worth of content?

    So, just so someone knows, I just started getting malicious website warnings through AVG and Opera when coming here.



    Rest In Peace, Old Friend.

  9. #29

    Default Re: Woah, did the forum just lose months and months worth of content?

    Quote Originally Posted by TheEconomist View Post
    Don't let them get to you!
    AH!!

    They got me! tell my family I love them! D:

    "So, just so someone knows, I just started getting malicious website warnings through AVG and Opera when coming here."

    That's not good.

  10. #30
    TheEconomist's Avatar Lord of Economics
    Join Date
    May 2009
    Posts
    6,895

    Default Re: Woah, did the forum just lose months and months worth of content?

    Yep, no one where else either. Even the more dangerous sites



    Rest In Peace, Old Friend.

Similar Threads

  1. Three months gone - Evolution of meta?
    By SaZun in forum StarCraft II Discussion
    Replies: 13
    Last Post: 08-15-2011, 07:12 AM
  2. How would you rate SC2, 7 months after release?
    By dustinbrowder in forum StarCraft II Discussion
    Replies: 66
    Last Post: 02-08-2011, 04:14 AM
  3. It seemed like I was suppose to lose, but I won somehow
    By alexamasan in forum StarCraft II Discussion
    Replies: 7
    Last Post: 04-17-2010, 11:23 PM
  4. Beta "practically" Confirmed 3-4 months
    By RedPineApple in forum StarCraft II Discussion
    Replies: 16
    Last Post: 02-26-2010, 05:18 PM
  5. All the new video's we've seen are well over 2-3 months old
    By Wankey in forum StarCraft II Discussion
    Replies: 4
    Last Post: 08-18-2009, 08:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •